aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2014-05-13 20:30:02 +0200
committerLukas Fleischer <calcurse@cryptocrack.de>2014-05-18 11:02:42 +0200
commit27b39a56ef8a2cf94ace5911614d0bd63c26ba06 (patch)
tree92894d27c67f49033cb02c85584986311a4d1e0e /src/Makefile.am
parent7184da0fa364049424f626f55f7c2bc0a7d22929 (diff)
downloadcalcurse-27b39a56ef8a2cf94ace5911614d0bd63c26ba06.tar.gz
calcurse-27b39a56ef8a2cf94ace5911614d0bd63c26ba06.zip
Add a generic list box implementation
This adds a very generic list box implementation. List boxes with items of different heights are supported. Two callback functions to determine the height of every single item and to draw a specific item are used. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3559a25..d17da42 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,6 +23,7 @@ calcurse_SOURCES = \
ical.c \
io.c \
keys.c \
+ listbox.c \
llist.c \
note.c \
notify.c \