summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..85c8a1d
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,31 @@
+AUTOMAKE_OPTIONS = foreign
+
+TESTS = \
+ true-001.sh \
+ run-test-001.sh \
+ run-test-002.sh \
+ todo-001.sh \
+ todo-002.sh \
+ todo-003.sh \
+ day-001.sh \
+ day-002.sh \
+ day-003.sh \
+ range-001.sh \
+ range-002.sh \
+ range-003.sh \
+ appointment-001.sh \
+ next-001.sh \
+ search-001.sh
+
+TESTS_ENVIRONMENT = \
+ CALCURSE='$(top_builddir)/src/calcurse' \
+ DATA_DIR='$(top_srcdir)/test/data/'
+
+AM_CFLAGS = -std=c99 -pedantic -D_POSIX_C_SOURCE=200809L
+
+check_PROGRAMS = run-test
+check_SCRIPTS = $(TESTS)
+
+run_test_SOURCES = run-test.c
+
+EXTRA_DIST = $(TESTS) data/apts data/conf data/todo