aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d88463b..44f20cc 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -51,18 +51,21 @@ TESTS = \
recur-005.sh
TESTS_ENVIRONMENT = \
+ TEST_INIT='$(top_srcdir)/test/test-init.sh' \
CALCURSE='$(top_builddir)/src/calcurse' \
DATA_DIR='$(top_srcdir)/test/data/'
AM_CFLAGS = -std=c99 -pedantic -D_POSIX_C_SOURCE=200809L
check_PROGRAMS = run-test
-check_SCRIPTS = $(TESTS)
+check_SCRIPTS = test-init.sh
+noinst_SCRIPTS = $(check_SCRIPTS)
run_test_SOURCES = run-test.c
EXTRA_DIST = \
$(TESTS) \
+ test-init.sh \
data/apts \
data/apts-bug-002 \
data/apts-recur \