aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am34
1 files changed, 24 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 16e4025..3f2c1b5 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,17 +1,31 @@
-# $calcurse: Makefile.am,v 1.5 2007/07/23 19:24:03 culot Exp $
+# $calcurse: Makefile.am,v 1.6 2007/07/28 15:04:52 culot Exp $
AUTOMAKE_OPTIONS= gnu
+
bin_PROGRAMS= calcurse
-calcurse_SOURCES= calcurse.c apoint.c event.c todo.c utils.c\
- calendar.c vars.c io.c help.c custom.c args.c\
- day.c recur.c notify.c wins.c sigs.c \
- apoint.h event.h todo.h utils.h calendar.h\
- vars.h io.h help.h custom.h args.h i18n.h\
- day.h recur.h notify.h wins.h sigs.h
-LIBS= -lncurses -lpthread -lm
+
+calcurse_SOURCES= \
+ calcurse.c i18n.h \
+ apoint.c apoint.h \
+ args.c args.h \
+ calendar.c calendar.h \
+ custom.c custom.h \
+ day.c day.h \
+ event.c event.h \
+ help.c help.h \
+ io.c io.h \
+ notify.c notify.h \
+ recur.c recur.h \
+ sigs.c sigs.h \
+ todo.c todo.h \
+ utils.c utils.h \
+ vars.c vars.h \
+ wins.c wins.h
+
LDADD= @LTLIBINTL@
+
datadir= @datadir@
+
localedir= $(datadir)/locale
+
DEFS= -DLOCALEDIR=\"$(localedir)\" @DEFS@
-man_MANS= calcurse.1
-EXTRA_DIST= calcurse.1