aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-02-22 09:09:50 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-02-24 22:48:26 +0100
commitf76e1cce404418cef74772536f2f5ac3a79b7b99 (patch)
tree33092a24e52900695e48e45ea607d42e56004e2a /test/Makefile.am
parent423bfcc9accac29a43b5d01c1134083f147a35e5 (diff)
downloadcalcurse-f76e1cce404418cef74772536f2f5ac3a79b7b99.tar.gz
calcurse-f76e1cce404418cef74772536f2f5ac3a79b7b99.zip
test/: Use correct calcurse binary and data dir
We really don't want to use the calcurse(1) binary from "$PATH" here. Introduce an environment variable "$CALCURSE" which can be used specify the binary to use and set this variable to the binary located in the build directory by default. Similarly, add another environment variable "$DATA_DIR" that can be used to specify a data directory. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5036478..85c8a1d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -17,6 +17,10 @@ TESTS = \
next-001.sh \
search-001.sh
+TESTS_ENVIRONMENT = \
+ CALCURSE='$(top_builddir)/src/calcurse' \
+ DATA_DIR='$(top_srcdir)/test/data/'
+
AM_CFLAGS = -std=c99 -pedantic -D_POSIX_C_SOURCE=200809L
check_PROGRAMS = run-test