aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-01-20 16:08:45 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-01-21 23:06:32 +0100
commite66e2d4277998094ee58ebd7c9455507df303939 (patch)
tree3015583bd679bf0c044a72af72c7deef5fd9ffd7 /test/Makefile.am
parent7a230fa76a5a0f5ada7b6afd2c42b2f99a549569 (diff)
downloadcalcurse-e66e2d4277998094ee58ebd7c9455507df303939.tar.gz
calcurse-e66e2d4277998094ee58ebd7c9455507df303939.zip
Add a minimal test suite
Introduce a new "test/" sub-directory that contains tests for calcurse. Right now, it only includes the quick-and-dirty "run-test" helper that can be used to run and verify tests: $ ./run-test test-1 test-2 test-3 test-4 Running test-1... ok Running test-2... ok Running test-3... FAIL Each argument passed to run-test must be a test script located in the current directory. run-test invokes each script twice and passes the command line argument "expected" and "actual", respectively. A test case succeeds if both "expected" and "actual" instances return with a zero exit status and produce exactly the same output. It fails otherwise. run-test terminates with a non-zero exit status as soon as one of the test fails. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..8b04cb8
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,6 @@
+AUTOMAKE_OPTIONS = foreign
+
+check_PROGRAMS = run-test
+
+run_test_SOURCES = run-test.c
+