aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-01-22 00:51:29 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-01-22 01:03:31 +0100
commitdbb19b7c25739518b36859dfd023ac9049770e45 (patch)
tree976d4d0061faae09e124c2913e43cc34362583af /test/Makefile.am
parent32530f0e50ba5cd4e3259f8f1868e28ae375ef20 (diff)
downloadcalcurse-dbb19b7c25739518b36859dfd023ac9049770e45.tar.gz
calcurse-dbb19b7c25739518b36859dfd023ac9049770e45.zip
test/: Add test cases for "-d" and "-s"/"-r"
* day-001.sh: Compare output of "-d<date>" with hardcoded data. * day-002.sh: Compare output of "-d<num>" with hardcoded data. * day-003.sh: Compare output of "-d<num>" with "-s<date> -r<num>". * range-001.sh: Compare output of "-r" with hardcoded data. * range-002.sh: Compare output of "-r<num>" with hardcoded data. * range-003.sh: Compare output of "-r<num>" with "-s<date> -r<num>". Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d98c727..d16b9d1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,7 +6,13 @@ TESTS = \
run-test-002.sh \
todo-001.sh \
todo-002.sh \
- todo-003.sh
+ todo-003.sh \
+ day-001.sh \
+ day-002.sh \
+ day-003.sh \
+ range-001.sh \
+ range-002.sh \
+ range-003.sh
check_PROGRAMS = run-test
check_SCRIPTS = $(TESTS)