aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-02-19 03:19:28 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-02-19 03:23:26 +0100
commit7c91248629ce2d9fd22ef58b88ad8ba760181277 (patch)
tree858ec492eb07a0a6c28ad6321b22970867c658e0 /test/Makefile.am
parent030db26ad3887b8d4b33e8eb98dfdbd146fa7509 (diff)
downloadcalcurse-7c91248629ce2d9fd22ef58b88ad8ba760181277.tar.gz
calcurse-7c91248629ce2d9fd22ef58b88ad8ba760181277.zip
{src,test}/Makefile.am: Enable pedantic warnings
Now that we're fully POSIX compliant and fixed up some minor issues with ISO C99, use "-std=c99 -pedantic -D_POSIX_C_SOURCE=200809L" as default build flags for calcurse and the test suite. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 238df35..62d9729 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -17,6 +17,8 @@ TESTS = \
next-001.sh \
search-001.sh
+AM_CFLAGS = -std=c99 -pedantic -D_POSIX_C_SOURCE=200809L
+
check_PROGRAMS = run-test
check_SCRIPTS = $(TESTS)