aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-01-21 15:28:51 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-01-22 00:13:35 +0100
commit32530f0e50ba5cd4e3259f8f1868e28ae375ef20 (patch)
tree6881ac69392cdb55698d38d3792d3c6dc269fdb5 /test/Makefile.am
parent31b4c71eb2610471cb0598338f510633f407477f (diff)
downloadcalcurse-32530f0e50ba5cd4e3259f8f1868e28ae375ef20.tar.gz
calcurse-32530f0e50ba5cd4e3259f8f1868e28ae375ef20.zip
test/: Add generic tests for todo operations
* todo-001.sh: Tests the "-t" command line option (calculates expected output by parsing the todo data file). * todo-002.sh: Tests "-t<num>" in a way similar to todo-001.sh. * todo-003.sh: Tests "-t0" in a way similar to todo-001.sh. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a478a8b..d98c727 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -3,7 +3,10 @@ AUTOMAKE_OPTIONS = foreign
TESTS = \
true-001.sh \
run-test-001.sh \
- run-test-002.sh
+ run-test-002.sh \
+ todo-001.sh \
+ todo-002.sh \
+ todo-003.sh
check_PROGRAMS = run-test
check_SCRIPTS = $(TESTS)