aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2015-02-23 10:43:54 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2015-02-23 10:46:16 +0100
commit1ea97795be8f9b8d63c5266ac7ea4889c3224a4d (patch)
tree7fdaaf4eaeb4b564b1479b375fef87a561c95bed /test/Makefile.am
parent4efa3f3fbf5525e37d7bae4bd8ed5ce747a0b32f (diff)
downloadcalcurse-1ea97795be8f9b8d63c5266ac7ea4889c3224a4d.tar.gz
calcurse-1ea97795be8f9b8d63c5266ac7ea4889c3224a4d.zip
Add support for UTC times in iCal imports
According to the iCal standard (4.3.12 Time): UTC time, or absolute time, is identified by a LATIN CAPITAL LETTER Z suffix character (US-ASCII decimal 90), the UTC designator, appended to the time value. Parse such time values properly when importing iCal files. Fixes GitHub issue #3. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fe205a2..efc3d12 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -48,6 +48,7 @@ TESTS = \
ical-004.sh \
ical-005.sh \
ical-006.sh \
+ ical-007.sh \
next-001.sh \
search-001.sh \
bug-002.sh \
@@ -111,4 +112,5 @@ EXTRA_DIST = \
data/ical-004.ical \
data/ical-005.ical \
data/ical-006.ical \
+ data/ical-007.ical \
data/todo