aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-11-26 19:27:16 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-11-26 20:23:05 +0100
commit0715a4433cc2c602458cbcb2bf0b1de15d63439b (patch)
tree9f45e46eb0028e533752be7b1e60387958a3096c /test/Makefile.am
parent4e28e8a9cc2ce6e81833d71270a74f0f55a540fc (diff)
downloadcalcurse-0715a4433cc2c602458cbcb2bf0b1de15d63439b.tar.gz
calcurse-0715a4433cc2c602458cbcb2bf0b1de15d63439b.zip
test/: Add a couple of tests for recurrent items
This adds tests for following features/scenarios: * Recurrent appointments and events of all (repetition) types. * Recurrent appointments with a duration of more than 24 hours. * Overlapping recurrent appointments. * Recurrent items and leap years. * Recurrent items with an end date. * Recurrent items with exceptions. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 354a46e..76a40fb 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -16,7 +16,12 @@ TESTS = \
appointment-001.sh \
next-001.sh \
search-001.sh \
- bug-002.sh
+ bug-002.sh \
+ recur-001.sh \
+ recur-002.sh \
+ recur-003.sh \
+ recur-004.sh \
+ recur-005.sh
TESTS_ENVIRONMENT = \
CALCURSE='$(top_builddir)/src/calcurse' \