aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-06-26 12:04:39 +0200
committerLukas Fleischer <calcurse@cryptocrack.de>2012-06-30 14:34:35 +0200
commit9ed7494f5e0b20c9a210520ba42fecd4ed51baf2 (patch)
treeffe374bf0130a6a3ced2cac2dd6ae67269076515 /src/Makefile.am
parentba28426fc0788d52ac7128c2dcd7afeff8be1127 (diff)
downloadcalcurse-9ed7494f5e0b20c9a210520ba42fecd4ed51baf2.tar.gz
calcurse-9ed7494f5e0b20c9a210520ba42fecd4ed51baf2.zip
Move interaction functions to a separate file
This is a first step to clean up several compilation units and separate the front end from back-end operations. All functions that require user interaction are moved to a new compilation unit "interaction.c". Also, following things are adjusted to the new layout: * Make day_item_get_*() and a few other functions public, so that it can be accessed from the new compilation unit. * Use apoint_hilt(), todo_hilt(), etc. instead of directly accessing static variables. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7eab77f..cb44177 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,6 +21,7 @@ calcurse_SOURCES = \
getstring.c \
help.c \
ical.c \
+ interaction.c \
io.c \
keys.c \
llist.c \