aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2011-05-31 20:04:03 +0200
committerLukas Fleischer <calcurse@cryptocrack.de>2011-06-29 15:43:44 +0200
commit271457b7a4753c0ee79fe0ee5105b7e496a8d240 (patch)
tree3fd446969c3ce563e59ec7eabc3a33a3337c269c /src/Makefile.am
parent7f5fc0c62f824282b910a573baf6c2712ca33cbe (diff)
downloadcalcurse-271457b7a4753c0ee79fe0ee5105b7e496a8d240.tar.gz
calcurse-271457b7a4753c0ee79fe0ee5105b7e496a8d240.zip
Add basic UTF-8 helper functions
Add utf8_width() and utf8_strwidth() which can be used to calculate the display width of a single character or a string, respectively. A lookup table is used to spot double width characters, as well as composing characters. There currently isn't any code to deal with ambigious characters. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index faacf46..b24a51d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,6 +22,7 @@ calcurse_SOURCES = \
recur.c \
sigs.c \
todo.c \
+ utf8.c \
utils.c \
vars.c \
wins.c \