aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2011-12-16 23:05:46 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-01-07 12:41:51 +0100
commit5dc443fc3d236fc2520df58495e62f197a98a64f (patch)
tree31dc2272f92ebfdb88722f78e7c34c5cff6e47ef /src/Makefile.am
parent7850f6ddf118abdb6e494b1c240776227d65cf54 (diff)
downloadcalcurse-5dc443fc3d236fc2520df58495e62f197a98a64f.tar.gz
calcurse-5dc443fc3d236fc2520df58495e62f197a98a64f.zip
Break out different import/export formats
Extract iCal and pcal import/export routines into separate files. This reduces complexity of the super huge "io.c" source file and makes it easier to follow changes that affect the iCal and pcal routines only (commits affecting both formats are very uncommon). Before: $ wc -l src/io.c 2938 src/io.c After: $ wc -l src/{io,ical,pcal}.c 1445 src/io.c 1263 src/ical.c 317 src/pcal.c 3025 total Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5942b89..f6be9e8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,11 +18,13 @@ calcurse_SOURCES = \
event.c \
getstring.c \
help.c \
+ ical.c \
io.c \
keys.c \
llist.c \
note.c \
notify.c \
+ pcal.c \
recur.c \
sha1.c \
sigs.c \