aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2012-01-20 16:08:45 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2012-01-21 23:06:32 +0100
commite66e2d4277998094ee58ebd7c9455507df303939 (patch)
tree3015583bd679bf0c044a72af72c7deef5fd9ffd7 /configure.ac
parent7a230fa76a5a0f5ada7b6afd2c42b2f99a549569 (diff)
downloadcalcurse-e66e2d4277998094ee58ebd7c9455507df303939.tar.gz
calcurse-e66e2d4277998094ee58ebd7c9455507df303939.zip
Add a minimal test suite
Introduce a new "test/" sub-directory that contains tests for calcurse. Right now, it only includes the quick-and-dirty "run-test" helper that can be used to run and verify tests: $ ./run-test test-1 test-2 test-3 test-4 Running test-1... ok Running test-2... ok Running test-3... FAIL Each argument passed to run-test must be a test script located in the current directory. run-test invokes each script twice and passes the command line argument "expected" and "actual", respectively. A test case succeeds if both "expected" and "actual" instances return with a zero exit status and produce exactly the same output. It fails otherwise. run-test terminates with a non-zero exit status as soon as one of the test fails. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index debd8b8..0500722 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,8 @@ AM_XGETTEXT_OPTION([--no-location --keyword=_ --keyword=N_])
#-------------------------------------------------------------------------------
# Create Makefiles
#-------------------------------------------------------------------------------
-AC_OUTPUT(Makefile doc/Makefile src/Makefile po/Makefile.in po/Makefile)
+AC_OUTPUT(Makefile doc/Makefile src/Makefile test/Makefile po/Makefile.in \
+ po/Makefile)
#-------------------------------------------------------------------------------
# Summary
#-------------------------------------------------------------------------------