aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Culot <calcurse@culot.org>2008-12-08 20:49:48 +0000
committerFrederic Culot <calcurse@culot.org>2008-12-08 20:49:48 +0000
commitdd9f739d8a0f03ef4059a6380deaadd02181f869 (patch)
tree9dbe4a79b40bc938126c425994ad2554b89097f9 /configure.ac
parentfe7e7186c41feef2a1ea71fea14dda6e8d571827 (diff)
downloadcalcurse-dd9f739d8a0f03ef4059a6380deaadd02181f869.tar.gz
calcurse-dd9f739d8a0f03ef4059a6380deaadd02181f869.zip
prefer overridability and let people choose their own CFLAGS
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 0b1d484..b44c869 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $calcurse: configure.ac,v 1.25 2008/12/08 20:32:30 culot Exp $
+# $calcurse: configure.ac,v 1.26 2008/12/08 20:49:48 culot Exp $
#-------------------------------------------------------------------------------
# Init
@@ -56,20 +56,7 @@ AC_CHECK_HEADERS([math.h], [
#-------------------------------------------------------------------------------
# Compilation options
#-------------------------------------------------------------------------------
-AC_ARG_ENABLE(debug,
- AS_HELP_STRING([--enable-debug], [set CFLAGS for debug]),
- debug=$enableval)
-if test "$debug" != "yes"; then
- debug=no
- AC_DEFINE(DBG_DISABLED, 1, [Define to 1 if you do not want debug.])
- CFLAGS="$CFLAGS -O2 -Wall"
-else
- AC_DEFINE(DBG_ENABLED, 1, [Define to 1 if you want debug.])
- CFLAGS="$CFLAGS -g -ggdb -Wall"
-fi
-AC_MSG_CHECKING([if debug should be used])
-AC_MSG_RESULT($debug)
-AM_CONDITIONAL(DBG_ENABLED, test x$debug = xyes)
+CFLAGS="$CFLAGS -Wall"
#-------------------------------------------------------------------------------
# Create Makefiles
#-------------------------------------------------------------------------------