aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2011-03-03 18:46:15 +0100
committerLukas Fleischer <calcurse@cryptocrack.de>2011-03-03 18:53:31 +0100
commitaaa000cd5aeeba7f1862d46f777df29cca8e8fd3 (patch)
tree6442b129c13663ad36a3bdcb3d8c71f4a3811372 /configure.ac
parent91c9cac8983c6ed818664762cbe679cefbb0c38b (diff)
downloadcalcurse-aaa000cd5aeeba7f1862d46f777df29cca8e8fd3.tar.gz
calcurse-aaa000cd5aeeba7f1862d46f777df29cca8e8fd3.zip
Convert man page to AsciiDoc.
Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6bfbc94..0b50478 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,17 +81,30 @@ if test x"$use_asciidoc" = x"auto"; then
else
have_asciidoc=yes
fi
+ AC_PATH_PROG([A2X], [a2x])
+ if test -z "$A2X"; then
+ have_a2x=no
+ AC_MSG_WARN([a2x not found - man pages will be skipped!])
+ else
+ have_a2x=yes
+ fi
elif test x"$use_asciidoc" = x"yes"; then
AC_PATH_PROG([ASCIIDOC], [asciidoc])
if test -z "$ASCIIDOC"; then
AC_MSG_ERROR([AsciiDoc not found and "--with-asciidoc" specified!])
fi
+ AC_PATH_PROG([A2X], [a2x])
+ if test -z "$A2X"; then
+ AC_MSG_ERROR([a2x not found and "--with-asciidoc" specified!])
+ fi
have_asciidoc=yes
elif test x"$use_asciidoc" = x"no"; then
AC_MSG_WARN(["--without-asciidoc" specified - documentation will be skipped!])
have_asciidoc=no
+ have_a2x=no
fi
AM_CONDITIONAL(HAVE_ASCIIDOC, test $have_asciidoc = yes)
+AM_CONDITIONAL(HAVE_A2X, test $have_a2x = yes)
#-------------------------------------------------------------------------------
# Compilation options
#-------------------------------------------------------------------------------