aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2011-04-18 17:45:50 +0200
committerLukas Fleischer <calcurse@cryptocrack.de>2011-04-22 02:47:37 +0200
commitc5e4187590f37e9524a8e3fcb2bccb20f2e8b4eb (patch)
tree93ab3249dc521b846909a0fc763fd32c904331c8 /Makefile.am
parentcbd66b13b12d841f25711893709f19fb7905e6b3 (diff)
downloadcalcurse-c5e4187590f37e9524a8e3fcb2bccb20f2e8b4eb.tar.gz
calcurse-c5e4187590f37e9524a8e3fcb2bccb20f2e8b4eb.zip
Add Git version string support.
Introduce a script to auto-generate version strings. Use `git describe` to create descriptive version strings when building from a Git checkout, use ".version" files for release tarballs. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b37844b..3052b72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,3 +7,7 @@ SUBDIRS = doc po src
EXTRA_DIST = \
INSTALL \
ABOUT-NLS
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@