aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <calcurse@cryptocrack.de>2011-09-03 02:19:32 +0200
committerLukas Fleischer <calcurse@cryptocrack.de>2011-09-03 02:19:32 +0200
commitac50b5a11106576f24dca18e1d6ab4313d696013 (patch)
treeb7087f1b06f5991edea03c85f191f2bf740a733e /Makefile.am
parentb59070a49e292746edeb781733db25931a6a6e50 (diff)
downloadcalcurse-ac50b5a11106576f24dca18e1d6ab4313d696013.tar.gz
calcurse-ac50b5a11106576f24dca18e1d6ab4313d696013.zip
Add a configure setting to skip "doc/"
This should fix all remaining build issues with documentation generation. Finally. The new "--disable-docs" option should be used to skip documentation completely, whereas "--without-asciidoc" can be used if both manual and man page should not be rebuilt. As a consequence, "--without-asciidoc" can only be combined with "--enable-docs" if ready-made documentation already exists in "doc/". This is true for release tarballs (where we include prebuilt documentation for the sake of portability and simplicity), as well as for Git checkouts where the documentation has already been built earlier. Signed-off-by: Lukas Fleischer <calcurse@cryptocrack.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e17d2f..5dd1ed9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,11 @@ AUTOMAKE_OPTIONS= foreign
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc po src
+SUBDIRS = po src
+
+if ENABLE_DOCS
+SUBDIRS += doc
+endif
EXTRA_DIST = \
INSTALL \