aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/vdir/Makefile.am
diff options
context:
space:
mode:
authorvxid <maxime.treca@gmail.com>2019-03-02 16:12:15 +0100
committerLukas Fleischer <lfleischer@calcurse.org>2019-03-14 21:21:46 +0100
commitd26164fb725e22f8eebd8d94ad59cab3921b8a6f (patch)
treeb647b4588e2e71bf2260bc18eceeb2a0704c1d0f /contrib/vdir/Makefile.am
parent5eff08777b643c0e112921eb6cb78381361acb68 (diff)
downloadcalcurse-d26164fb725e22f8eebd8d94ad59cab3921b8a6f.tar.gz
calcurse-d26164fb725e22f8eebd8d94ad59cab3921b8a6f.zip
Add support for vdir synchronization
Add a script to synchronize calcurse with a VDIR collection. Add a wrapper script around vdirsyncer to automatically synchronize calcurse data to a vdirsyncer collection. Add script documentation and Makefile. Signed-off-by: Lukas Fleischer <lfleischer@calcurse.org>
Diffstat (limited to 'contrib/vdir/Makefile.am')
-rw-r--r--contrib/vdir/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/contrib/vdir/Makefile.am b/contrib/vdir/Makefile.am
new file mode 100644
index 0000000..2bb7f0b
--- /dev/null
+++ b/contrib/vdir/Makefile.am
@@ -0,0 +1,13 @@
+AUTOMAKE_OPTIONS = foreign
+
+dist_bin_SCRIPTS = \
+ calcurse-vdir
+
+EXTRA_DIST = \
+ calcurse-vdir.py
+
+CLEANFILES = \
+ calcurse-vdir
+
+calcurse-vdir: calcurse-vdir.py
+ cp "$(srcdir)/$<" "$@"