aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Culot <calcurse@culot.org>2006-09-09 20:00:16 +0000
committerFrederic Culot <calcurse@culot.org>2006-09-09 20:00:16 +0000
commit068881e0fc8e649c881fd894798cc426360b7960 (patch)
tree66f62f30e17127fe665d525f30a66dcd98bd1c9e /configure.ac
parentf6d01bec6a02e7117f951a8ff26bfed82c95f6d7 (diff)
downloadcalcurse-068881e0fc8e649c881fd894798cc426360b7960.tar.gz
calcurse-068881e0fc8e649c881fd894798cc426360b7960.zip
added test for pthread library and switched to version 1.6
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f536dd1..53915d8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
#
-# $calcurse: configure.ac,v 1.2 2006/08/24 20:11:26 culot Exp $
+# $calcurse: configure.ac,v 1.3 2006/09/09 20:00:16 culot Exp $
AC_PREREQ(2.59)
-AC_INIT(calcurse, 1.5, frederic@culot.org)
+AC_INIT(calcurse, 1.6, frederic@culot.org)
AM_INIT_AUTOMAKE
AM_GNU_GETTEXT([external])
AC_CONFIG_SRCDIR([src/calcurse.c])
@@ -21,6 +21,14 @@ AC_CHECK_HEADERS([ncurses.h], [
], AC_MSG_ERROR(The ncurses library is required in order to build the program!))
], AC_MSG_ERROR(The ncurses header is required in order to build the program!))
+# Checks for pthread.
+AC_CHECK_HEADERS([pthread.h], [
+ AC_CHECK_LIB(pthread, pthread_create, [
+ LIBS="$LIBS -lpthread"
+ AC_DEFINE(HAVE_LIBNCURSES, 1, [Define to 1 if you have the 'pthread' library (-lpthread).])
+ ], AC_MSG_ERROR(The pthread library is required in order to build the program!))
+], AC_MSG_ERROR(The pthread header is required in order to build the program!))
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([stdlib.h string.h sys/time.h time.h stdio.h unistd.h \